Windows SBS Server vs. Microsoft Exchange 2010 SP3

Sollte jemand wie ich auf eine Fehlermeldung: „Write-ExchangeSetupLog -Info „Creating SBS certificate“;“ beim Exchange Service Pack 3 Update am Punkt der Hub Transport Rolle eines Microsoft Windows Small Business Server stoßen, kann dieses Problem relativ schnell gelöst werden.

Fehlermeldung:

Hub-Transport-Rolle

Fehler

Fehler:

Der folgende Fehler wurde generiert, als „$error.Clear();

Write-ExchangeSetupLog -Info „Creating SBS certificate“;

$thumbprint = [Microsoft.Win32.Registry]::GetValue(„HKEY_LOCAL_MACHINE\Software\Microsoft\SmallBusinessServer\Networking“, „LeafCertThumbPrint“, $null)

if (![System.String]::IsNullOrEmpty($thumbprint))

{

Write-ExchangeSetupLog -Info „Enabling certificate with thumbprint: $thumbprint for SMTP service“;

Enable-ExchangeCertificate -Thumbprint $thumbprint -Services SMTP

Write-ExchangeSetupLog -Info „Removing default Exchange Certificate“;

Get-ExchangeCertificate | where {$_.FriendlyName.ToString() -eq „Microsoft Exchange“} | Remove-ExchangeCertificate;

Write-ExchangeSetupLog -Info „Checking if default Exchange Certificate is removed“;

$certs = Get-ExchangeCertificate | where {$_.FriendlyName.ToString() -eq „Microsoft Exchange“};

if ($certs)

{

Write-ExchangeSetupLog -Error „Failed to remove existing exchange certificate“

}

}

else

{

Write-ExchangeSetupLog -Warning „Cannot find the SBS certificate“;

}

“ ausgeführt wurde: „Das Zertifikat mit dem Fingerabdruck ’86BD426C4C863BE9DC64150AB6C98B09C01259AE‘ wurde nicht gefunden.“.

Das Zertifikat mit dem Fingerabdruck ’86BD426C4C863BE9DC64150AB6C98B09C01259AE‘ wurde nicht gefunden.

Hier klicken, um die Hilfe aufzurufen… http://technet.microsoft.com/de-DE/library/ms.exch.err.default(EXCHG.141).aspx?v=14.3.123.3&e=ms.exch.err.Ex88D115&l=0&cl=cp

Hierzu muß nur folgender Registry Wert gelöscht werden: (Achtung!: Änderungen an der Registry sollten nur von Personen mit dem nötigen IT Wissen durchgeführt werden. Es empfiehlt sich, vorher ein Backup der Registry durchzuführen)

HKEY_LOCAL_MACHINE/Software/Microsoft/SmallBusinesServer/Networking/LeafCertThumbprint

WICHTIG: Bitte löschen Sie nun den Wert des Key „LeafCertThumbprint“, nicht aber den Key selbst! Dieser wird zwingend weiterhin benötigt.

Anschließend sollte das Update ohne Fehlermeldung installiert werden können.

9 Gedanken zu „Windows SBS Server vs. Microsoft Exchange 2010 SP3“

  1. Vielen Dank für den Beitrag, der auch sehr vielversprechend aussah.
    Leider hat es bei mir nicht funktioniert, lag aber möglicherweise daran, dass ich vorher schon zu viel herumexperimentiert habe.
    Ich habe ein Image zurückspielen müssen und stehe wieder am Anfang.
    Gibt es eine Erklärung für den falschen Wert? Ich hatte die Zertifikate ca. 3 Wochen zuvor erneuert ohne auf sichtbare Fehler zu stoßen.
    Kann man den Key mit dem richtigen Wert manuell korrigieren?

    1. Hallo Herr Müller,
      der Key wird bei der Erstellung des Zertifikats über den SBS Server einmalig gesetzt und bei einem Zertifikatswechsel etc. leider nicht aktualisiert. Somit verweist der Key nun auf ein Zertifikat, dass nicht mehr vorhanden ist und führt somit zum Fehler bei der Update Installation. Den Wert selbst einzutragen habe ich bisher nie getestet, allerdings würde ich davon auch eher abraten, da der Key (nachdem der Wert einmal gelöscht wurde) automatisch erneut gesetzt wird. Sollte das nicht der Fall sein, gibt es wohl noch ein weiteres Problem. Wichtig ist -wie bei jeden Service Pack-, dass Setup über die Runas Funktion zu installieren, selbst wenn Sie derzeit als Domänen- bzw. lokaler Administrator angemeldet sind. Ich hoffe diese Informationen helfen Ihnen weiter und würde mich über einen weiteren Kommentar freuen, ob und wie der Fehler in Ihrem Fall gelöst werden konnte.

      1. Hallo Herr Maier,
        vielen Dank für Ihre Antwort.
        Ich habe den Reg. Key bei allen SBS 2011 meiner Kunden überprüft, der Wert wurde bei allen richtig erneuert. Es scheint daher kein genereller Fehler zu sein.
        Unabhängig vom Update auf SP3 sollte der Wert natürlich stimmen, obwohl ich bisher keine Auswirkungen gemerkt habe. Wenn ich den Wert lösche, wird er dann direkt oder erst nach einem Neustart durch den richtigen ersetzt? Bevor ich ein neues Update wage würde ich gerne erst mal das SP1 wieder in die Spur bringen. Haben Sie das Löschen des Wertes nur in Verbindung mit dem anschließenden Update getestet, oder ist das ein genereller Lösungsansatz?

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *